A sample text widget

Etiam pulvinar consectetur dolor sed malesuada. Ut convallis euismod dolor nec pretium. Nunc ut tristique massa.

Nam sodales mi vitae dolor ullamcorper et vulputate enim accumsan. Morbi orci magna, tincidunt vitae molestie nec, molestie at mi. Nulla nulla lorem, suscipit in posuere in, interdum non magna.

If you find this site helpful please consider a donation

I started this blog as a hobby a couple years ago. I never thought people would find it and I never imagined that it would become frequently accessed. However, over the past few months my hitcount has continued to grow and grow. You will notice that there are banners for Hopegivers International placed randomly around my blog. Christmas of 2009 I had the privilege of visiting India and seeing first hand the work of Hopegivers. I visited several orphanages and saw the great work being done taking children off of the street and giving them food, clothing, and a place to sleep.

If you have found something on this blog to be helpful, please consider giving to Hopegivers. Simply click on one of the banners or just go to http://www.hopegivers.org. Once you are there click on CONTRIBUTE. You will see several options. I assure you, anything you choose to give to will be a great choice. Oh, and one other thing, I don’t receive one red cent of the money you donate. I make nothing off of the banner clicks and I receive nothing off of the donations you make. And this organization has very low administrative costs, so your money isn’t going to pay for TV commercials or some executive’s fat salary. It is going to a good great cause.

I would really like you to consider adopting a hope home with a monthly donation. I assure you that Hopegivers is a good steward of your money.

Please give.

Thanks!

-Go0se

Audiotext Manager for Connection

If you use Cisco Unity Connection, you need to check out the Audiotext Manager for Connection tool from ciscounitytools.com. I would argue with whomever named this tool, as the name isn’t very descriptive. But someone liked the acronym “ATM” so I’m sure that’s why they named it what they did.


Click here to help support an orphan today!

I stumbled across a link to the tool when I was searching for a way to copy an existing call handler to a new call handler. I have not found a way to do this in the native UCXN admin tool. This tool gives you the ability to copy call handlers and much, much more.

Check out this video.

-Go0se

Howto: Configure the Forward No Answer timer on a Cisco Unified Communications Manager (Callmanager)

On a Cisco Callmanager, the amount of time a phone rings before it forwards to voice-mail (or whatever it is configured to forward to) is measured in seconds. (It is not measured by a number of rings.) This timer can be configured globally under the Cisco Callmanager Service Parameters, or locally on a per line basis, on the line settings under the Call Forward and Call Pickup Settings section in the No Answer Ring Duration field. The line setting, if configured, will override the global setting configured under Service Parameters. On the line level of a phone it is referred to as the “No Answer Ring Duration”. The global service parameter is referred to as the “Forward No Answer Timer”.

If you wish to change it globally, as I referenced above, you can change it under the service parameters with the following steps.

1) Log into your callmanager and click on SYSTEM | SERVICE PARAMETERS

System - Service Parameters

System – Service Parameters

2) Once the service parameters screen loads, select your publisher server in the SERVER drop-down box. In the SERVICE drop-down box, select CISCO CALLMANAGER

Callmanager Service

Callmanager Service

3) Now scroll down a little more than half way down the page and you’ll see CLUSTERWIDE PARAMETERS (FEATURE – FORWARD). Two lines down, you’ll see The FORWARD NO ANSWER TIMER field. The default is 12 seconds. (You will see the defaults to the right of the fields for all of the settings.) You can enter in a new value and click SAVE at the top of the page.

Forward No Answer Timer

Forward No Answer Timer


Click here to help support an orphan today!

If you wish to change it on an individual line follow these steps.
1) Find the phone you wish to edit
2) Click on the LINE to show the line settings
3) Scroll down and you’ll see the CALL FORWARD AND CALL PICKUP SETTINGS. Near the bottom you’ll see the NO ANSWER RING DURATION (SECONDS) field. Enter in the value you wish into this field and click SAVE at the top of the page.

Line Call Forward and Call Pickup Settings

Line Call Forward and Call Pickup Settings

When configuring these timers, be sure not to go overboard. If someone calls in to a line that forwards to voicemail, people aren’t very patient and they won’t wait a long time before hanging up.

Thanks,

Goose

Link: Configure the Forward No Answer Timeout in Unified Communications Manager

Howto: Configure a Cisco EHWIC-4G-LTE-A for use with AT&T

We have a small, unmanned remote location that cannot get DSL or cable Internet access and all other solutions are cost prohibitive so we decided to purchase a Cisco EHWIC-4G-LTE-A card. We are using AT&T as our carrier. I just got finished configuring it and so far it seems to be working well. It was quite simple to get it connected. As you can see by the config below, there isn’t a lot to it.


Cisco EHWIC-4G-LTE-A

!
!
ip dhcp excluded-address 10.45.123.1 10.45.123.99
!
ip dhcp pool lan-inside
network 10.45.123.0 255.255.255.0
dns-server 208.67.220.220 208.67.222.222
default-router 10.45.123.1
!
!
multilink bundle-name authenticated
!
!
chat-script lte “” “AT!CALL1” TIMEOUT 20 “OK”
crypto pki token default removal timeout 0
!
!
controller Cellular 0/0
!
interface GigabitEthernet0/0
description **** To “inside” interface ****
ip address 10.45.123.1 255.255.255.0
ip nat inside
no ip virtual-reassembly in
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
routing dynamic

!


Click here to help support an orphan today!

!
interface Dialer1
ip address negotiated

ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 1

!
ip forward-protocol nd
!
ip nat inside source route-map nat-to-cell interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
access-list 101 deny ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 101 permit ip 10.45.123.0 0.0.255.255 any
!
dialer-list 1 protocol ip list 1
!
route-map nat-to-cell permit 10
match ip address 101
!
!

I believe that’s all the important stuff. I’m going to let her run for a few days and I’ll report back and let you know what I think of it.

For a link to the Cisco configuration guide, click HERE.
Later,

Go0se

Meraki access point

I just received a free Meraki MR12 access point. Meraki has wifi, switches, and security appliances that are all managed by their cloud based management service. They are geared towards small and medium businesses and education. Their simplistic management interface reduces the need for organizations to hire additional IT staff to maintain even larger deployments. Meraki was recently purchased by Cisco so they are apparently doing something right. Meraki currently has a promotion where if you sign up for and attend one of their webinars, they will ship you a free MR12 access point (a $699 value) with 3 years of their cloud based service.


Click here to help support an orphan today!

You can sign up for their webinars here. The only hitch I’m aware of is that you must be able to prove that you are an IT professional. I don’t believe they’re available outside of the US and Canada.

Meraki MR12

Meraki also has a completely free mobile device management service. (You need to check it out.)

-Go0se

Singlewire InformaCast now included with Unified Communications Manager

Singlewire and Cisco have announced that the Singlewire InformaCast software will be bundled with Unified Communications Manager 9.1. InformaCast now comes in two versions, Basic and Advanced. Cisco is including the Basic version with Unified Communications Manager free of charge. The basic version will allow administrators to configure an unlimited number of paging groups, with a maximum number of 50 phones per group. Organizations requiring additional functionality or larger paging groups can purchase the Avanced version of InformaCast and unlock additional InformaCast features. These features include the ability to send text and audio clips to phones, interconnect with existing overhead paging systems, and the ability to broadcast messages to IP speakers, and several other features.


Click here to help support an orphan today!

To see a comaparison of the features available with the basic and advanced versions, as well as a list of pricing for the Advanced versions, click here.

Cisco has an .iso and an .ova download for the Basic version available under the Unified Communications Manager 9.1 downloads (login required).

-Go0se

Howto: configure Cisco wireless bridging with multiple VLANs

Configuring wireless gear has never been my favorite task. I like absolutes. Give me a router and a T1 and it will either work or it won’t work. When it doesn’t work, there’s a reason that can be remedied. With wireless gear, it might work… or it might not. Or it might work today, but tomorrow someone else throws out some wireless gear near yours and yours may quit working… or work poorly. Too many variables that are out of my control. Anyway, I’ve configured numerous wireless bridging links utilizing Cisco Aironet wireless equipment. 1300 series and 1400 series bridges. However, I’ve never trunked VLANs across a wireless bridging link until lately. I had an existing link between two Cisco Aironet 1410 bridges at two separate buildings, about 4 blocks apart. We were actually using the link as a small WAN link and we were routing across it because we didn’t want a huge broadcast domain. Well, we had a new VLAN that we needed in both buildings but we also wanted to leave the routed link in tact. After pounding my head against the wall a little bit, I got it to work. Below are some scrubbed configs that might help you along in your task of configuring the same. The root bridge is first, followed by the non-root bridge and then finally the switch port configs of the switches that are connected to these bridges.

Here’s the config from the ROOT bridge. The management IPs of the bridges are in VLAN 40.

! *^*^*^*^*^*^*^*^*^*^*^*^*^*^*^
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname root-br
!
logging rate-limit console 9
enable secret ********************
!
!
aaa session-id common
clock timezone CST -6
clock summer-time CDT recurring
ip domain name go0se.com
!
!
no dot11 igmp snooping-helper
dot11 syslog
dot11 vlan-name data-vlan vlan 20
dot11 vlan-name management-vlan vlan 40
!
dot11 ssid go0se-wifi-bridge
vlan 40
authentication open
authentication key-management wpa
infrastructure-ssid
wpa-psk ascii ************************
!
!
!
username admin password ************************
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 40 mode ciphers tkip
!
ssid go0se-wifi-bridge
!
station-role root
rts threshold 4000
cca 0
concatenation
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 40 native
no ip route-cache
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 20
no ip route-cache
bridge-group 2
!
interface FastEthernet0
no ip address
no ip route-cache
!
interface FastEthernet0.1
encapsulation dot1Q 40 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 20
no ip route-cache
bridge-group 2
!
interface BVI1
ip address 10.40.0.10 255.255.255.0
no ip route-cache
!
ip default-gateway 10.40.0.1
ip http server
!
bridge 1 route ip
!
!
banner motd ^

+——————————————————————-+
| |
| *** Unauthorized Use or Access Prohibited *** |
| |
| For Authorized Official Use Only |
| |
+——————————————————————-+

^
!
line con 0
password ************************
transport output all
line vty 0 4
password ************************
transport input ssh
transport output all
line vty 5 15
password ************************
transport input ssh
transport output all
!
end


Click here to help support an orphan today!


! *^*^*^*^*^*^*^*^*^*^*^*^*^*^*^

Here’s the config of the NON-ROOT bridge.

! *^*^*^*^*^*^*^*^*^*^*^*^*^*^*^
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname non-root-br
!
logging rate-limit console 9
no logging console
enable secret ************************
!
clock timezone CST -6
clock summer-time CDT recurring
ip domain name go0se.com
!
!
no dot11 igmp snooping-helper
dot11 syslog
dot11 vlan-name data-vlan vlan 20
dot11 vlan-name management-vlan vlan 40
!
dot11 ssid go0se-wifi-bridge
vlan 40
authentication open
authentication key-management wpa
infrastructure-ssid
wpa-psk ascii ************************
!
!
!
username admin password ************************
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 40 mode ciphers tkip
!
ssid go0se-wifi-bridge
!
station-role non-root
rts threshold 4000
cca 0
concatenation
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 40 native
no ip route-cache
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 20
no ip route-cache
bridge-group 2
!
interface FastEthernet0
no ip address
no ip route-cache
!
interface FastEthernet0.1
encapsulation dot1Q 40 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 20
no ip route-cache
bridge-group 2
!
interface BVI1
ip address 10.40.0.11 255.255.255.0
no ip route-cache
!
ip default-gateway 10.40.10.1
ip http server
no ip http secure-server
!bridge 1 route ip
!
!
banner motd ^

+——————————————————————-+
| |
| *** Unauthorized Use or Access Prohibited *** |
| |
| For Authorized Official Use Only |
| |
+——————————————————————-+

^
!
line con 0
password ************************
transport output all
line vty 0 4
password ************************
transport input ssh
transport output all
line vty 5 15
password ************************
transport input ssh
transport output all
!
sntp server 10.40.0.1
end
! *^*^*^*^*^*^*^*^*^*^*^*^*^*^*^

Here’s the switchport config. The same config is used on each switch.

! *^*^*^*^*^*^*^*^*^*^*^*^*^*^*^
!
interface FastEthernet1/0/48
description Trunk to root wireless bridge
switchport trunk encapsulation dot1q
switchport trunk native vlan 40
switchport mode trunk
!
! *^*^*^*^*^*^*^*^*^*^*^*^*^*^*^

If you need to add additional VLANs, simply add additional subinterfaces with the proper VLAN encapsulation. As an example, if you want to add a VLAN 60, simply add the following script to BOTH bridges:

!
interface Dot11Radio0.3
encapsulation dot1Q 60
no ip route-cache
bridge-group 3
!
!
interface FastEthernet0.3
encapsulation dot1Q 60
no ip route-cache
bridge-group 3
!

Here is a Cisco guide that might assist as well.

Hope this helps.

Later,

Go0se

Motorola Xoom tablet

I’ve had my Motorola Xoom tablet for just over a week and I love it. I’ve always thought that it would be nice to have a tablet but I never really thought it would be that big of a deal. Well, I was wrong. I can’t say enough about it. About the only complaint I have is that there isn’t a Cisco AnyConnect VPN client for it. As soon as I have the time I’m going to configure my Cisco ASA for the L2TP/IPSec VPN. I’ll try to post a config after I get it working.

Xoom

Motorola Xoom

I also ordered and received an Ottebox Defender for Motorola Xoom case. My son and daughter each have an iPad 2 and we purchased Otterbox Defender cases for those so I had a good idea of what I was getting. I wanted a case that would be functional and protective. The Otterbox Defender fits the bill. Below is a video made by Otterbox for the case.

If you are an Android user and have some really good useful apps, leave me a reply below and let me know what you use.

-Go0se

Ubiquiti wireless gear

A coworker of mine recently introduced me to Ubiquiti Networks, makers of wireless gear. We just purchased a pair of their NanoBridge NB-5G25 wireless bridges. They are 5GHz 25dBi dishes with the bridges integrated into the “cone”. Per their datasheet they claim to be “capable of 100+Mbps real outdoor throughput and up to 30km+ range.” We are going to shoot between sites that are just a little over 3 miles apart. We ordered them from streakwave.com. (If you call them ask for Greg and tell him Go0se sent you.)


Click here to help support an orphan today!

We purchased them for a little over $100 a piece, shipped! Compare that to purchasing a pair of Cisco Aironet 5GHz 1410 series bridges for a street price of around $3500+ each and then separately a pair of their 28dBi dishes for a street price of $900+ each, or over $8800 total for a point-to-point link. We can purchase around 80 of these Ubiquiti bridges for the cost of two Cisco Aironet 5GHz bridges with dishes. It makes Cisco look obscene. And on top of that the Cisco bridges are only capable of 54Mbps throughput. I will admit that I am skeptical and I question their quality and durability. If they work well I’ll let you know… if they are junk I’ll let you know that as well. I’ll try to update this post once I’ve gotten them installed and then hopefully again after they’ve run for a while to let you know what I find out.

Ubiquiti

Ubiquiti

Ubiquiti

-Go0se

UPDATE: 8/23/2011 – It’s been a crazy busy past few weeks. We indeed got our bridges installed but we don’t have a great signal. Actually, most of the time we have no signal. But I do not believe it is the equipment’s fault. We have zoning restrictions that restrict how high we can mount the equipment and on both buildings the dishes are just slightly above the top of the building and according to specs, we’re not high enough for the distance we are trying to connect over.

Howto: clean the Hookswitch on a Cisco IP phone

If you are reading this, odds are you have a Cisco IP phone that is in relatively good condition, the only problem with it is the hookswitch mechanism is messed up and therefore the phone is prettymuch useless. This is common on Cisco phones. Today I will specifically cover how to disassemble a Cisco 7970 phone and troubleshoot the hookswitch mechanism. With a little patience you can take apart the phone and revive the hookswitch with a little cleaning.

***WARNING*** I TAKE ABSOLUTELY NO RESPONSIBILITY FOR ANY DAMAGE TO YOUR PHONE. PROCEED AT YOUR OWN RISK. ALSO BE AWARE THAT THIS MAY VOID YOUR WARRANTY!!

NOTE: The procedure for the 7970 series phones is somewhat different than the Cisco 7940/60 7941/61 7942/62 series phones. I have not taken apart any of the 42/62 series, but the 40/60 & 41/61 series do not have a bezel or screws on the front side.

First, unplug all cables from the phone and flip it over so the back (non button side) is facing you. There are 4 screws to remove on the back. Two in plain sight, two under the rubber feet near the bottom rear of the phone.

rear screws

You can pull the top half of the rubber feet back to reveal the screw holes.

feet screws

Once you have removed the rear screws, flip the phone over so the front (button side) is facing you. Now you need to temporarily remove the bezel that surrounds the screen and overlays the softkeys and line buttons.

bezel

Start at the top and gently pry the bezel out from the phone. Once the top is lifted away, gently pull the bezel up and away. There are five small tabs at the bottom that hold it down and into the phone case.

bezel away

Once the bezel has been removed, you will see three screws along the top (above the screen). Remove these screws.

bezel screws


Click here to help support an orphan today!

There is one final screw that is behind the little receiver clip. Gently pop the receiver clip off and remove the screw that is under it. Note on the photo below the grime that has accumulated around the handset cradle area. My opinion is that this is probably what causes a lot of the damage to hookswitches. I have noticed that this is more prevalent on ladies phones, I assume that this is most likely from makeup that has rubbed off onto the handset and then transferred onto/into the phone.

clip screw

Once these screws have been removed flip the phone back over so that the back of the phone (the non-button side) is facing you. Gently pry the rear cover from the phone. Be careful as you remove the cover. There is a small tension spring that applies pressure to the hookswitch. Be sure it doesn’t get lost. Also make a note of how the tension spring is attached.

spring

Once the back has been removed, remove the tension spring. You can now remove the hookswitch activator. On the 7970 you can swivel it 90 degrees and remove it. On the 7940/60 41/61 series it is easier to remove the hookswitch board screw and pull the hookswitch board out from under the hookswitch. Once this is removed, clean any grime/goo, etc., that has accumulated around the hookswitch opening and on the hookswitch activator itself.

hookswitch

If you haven’t already removed the hookswitch board, remove it. Unscrew the screw in the middle of the board, and follow the hookswitch cable down to where it plugs into the main processor board of the phone and unplug the cable. Remove the hookswitch board.

hookswitch board

Once you have the hookswitch board/cable assembly removed, there is a small rubber piece pressed into the board. Gently remove it by simply prying it away from the board.

hookswitch board

Once you have it removed, clean the metal contact points on the board with an eraser. Be sure not to leave any eraser residue on the contact points. I also like to clean the rubber piece with an alcohol pad.

hookswitch rubber cover

The trickiest part is getting the rubber cover back on the board. Once you have thoroughly cleaned the contact points and the rubber cover, align the rubber cover properly with the holes on the board. It will only line up one way. Gently press the small rubber protrusions back into the hookswitch board. This isn’t easy. Once you have wiggled them into the board enough that they protrude out the back side a little bit, take some needle nose pliers and pull them thru until the rubber cover is pressed back flat against the hookswitch board.

Once you have cleaned and reassembled hookswitch board, simply reverse the steps above to reassemble the phone and you are done!

For the Cisco cleaning guide click here

Cisco Press $9.99 ebook deal of the day

Ciscopress.com has started a $9.99 eBook Deal of the Day promotion. Every day they offer an eBook for $9.99. They are typically DRM-free .PDF documents – they simply watermark your name in the bottom RH corner of every page of the PDF.

Check it out.

-Go0se